It is currently 18-12-2017 04:13

В HTTP/2 обнаружены пять опасных уязвимостей

В HTTP/2 обнаружены пять опасных уязвимостей

by sigismund » 2016-08-04 11:55:23


Некоторые из брешей позволяют осуществить DoS-атаку.


ИБ-исследователи Imperva обнаружили пять опасных уязвимостей в новой версии HTTP-протокола - HTTP/2. Проанализировав реализацию серверной части HTTP/2 от Apache, Microsoft, NGINX, Jetty и nghttp2, эксперты сумели выявить уязвимости во всех главных механизмах HTTP/2. Среди обнаруженных брешей оказались две уязвимости, которым подвержена версия HTTP/1.x.

Одна из уязвимостей (CVE-2016-1546) позволяет злоумышленнику использовать вредоносный клиент для очень медленного чтения ответов, тем самым провоцируя отказ в обслуживании. Атакующий способен использовать настройки HTTP/2 для мультиплексирования большого количество каналов через одно TCP-соединение. Несмотря на то, что сервер поддерживает одно TCP-соединение, он выделяет поток для каждого канала, что может привести к потреблению всех доступных потоков на уязвимом сервера.

Уязвимость HPACK Bomb включает две бреши (CVE-2016-1544, CVE-2016-2525), позволяющие атакующему создать небольшое по виду сообщение, которое на самом деле распаковывает гигабайты данных на стороне сервера. Злоумышленник может потребить все доступные ресурсы на системе и вызвать отказ в обслуживании.

Брешь CVE-2015-8659 влияет на механизмы управления потоком, используемые HTTP/2 для оптимизации сети. С помощью специально сформированных запросов атакующий может вызвать зацикливание приложения. Эксплуатация уязвимости позволяет осуществить DoS-атаку или выполнить произвольный код на системе.

Уязвимость CVE-2016-0150 связана с мультиплексированием потока, когда несколько сессий проходят через одно HTTP/2-соединение. Так как разделение связи является исключительно логическим, атакующий может воспользоваться этим для манипулирования сервером. Эксплуатация бреши позволяет осуществить DoS-атаку.
sigismund
moderators
Сообщений: 788
Депозит: 0 BTC

Rating: 5